SSH keys not being added to authorized_users file

Gogs version and commit
Application version
0.12.3
Git version
2.20.1
Go version
go1.15
Build time
2020-10-07 03:43:11 UTC
Build commit
f0e3cd9

Running in docker container on Arch Linux 5.14.2-arch1-2 x86_64

Database
MARIADB_MAJOR | 10.6
MARIADB_VERSION | 1:10.6.4+maria~focal

Tried reproducing on test site however cannot create new repositories.

So I recently migrated from a raspberry pi implementation to running in a docker container on another machine. Everything works fine EXCEPT that I can’t connect to the repo via SSH. I get the following response :

ssh: connect to host git.host.com port 12022: Connection refused
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

I suspect it’s because theres no authorized_users file. I checked the database and the keys are in the table public_key so that’s not the issue. I tried copying the authorized_users file over but no luck so then I changed the first part to read command="/app/gogs/gogs serv key-1 --config='/data/gogs/conf/app.ini'",no-port-forwarding,no-X11-forwarding,no-agent-forwarding,no-pty rather than the raspberry pi’s version of command="/home/git/gogs/gogs serv key-1 --config='/home/git/gogs/custom/conf/app.ini'",no-port-forwarding,no-X11-forwarding,no-agent-forwarding,no-pty to more accurately describe the container directory layout however that didn’t work either.

UPDATE:
So I had a firewall issue as well as another issue but the issue still remains that uploading an SSH key does not update the authorised_usres file as I tried adding an additional SSH key and it didn’t update I have to manually go in and update it.
UPDATE 2:
I started from a blank image because I screwed some things up following this guide use port 22 and SSH keys doesn’t work on fresh installs, unless you manually change authorized_users.

Any help is appreciated!

I figure it out, not really sure what it was exactly but after playing around with things i got it working