Need to set is_bare from repository always to 0

I recently setup gogs.

And I’m using SSH server from my OS side (not inbuilt from gogs)

So for this i face issue on SSH url which doesn’t include the directory name gogs-repositories.

To fix this I’ve moved all content for the files in that “gogs-repository” folder to parent one. (where ssh user lands)

So that SSH link works smooth. The only issue i face now is, I don’t see any files in gogs gui for repositories

If i do manually change . "is_bare " value from 1 to 0 for that particular repository on mysql repository table it works good.

By default that value assigns to 1, How can we set it to 0 by default.

Thanks.

Please consider reading How to config SSH settings. directory should not be included, otherwise Gogs is not included in the SSH communication for your repositories and Gogs’s behavior undefined.