Gogs stops running


#1

Hello, Installed the latest version of Gogs Version: 0.11.19.0609 on server running apache and centos 7 using mysqlite3. Gogs installs correctly but, after a few minutes I can no longer login or see the Gogs home page and have to restart Gogs with the following command:
./gogs web &. Then I control c to exit.
Tried uninstalling and reinstalling, same thing happens. Does anyone else have this issue or know what it is?

This is the error I receive in chrome:

This site can’t be reached
refused to connect. Try:Checking the connectionChecking the proxy and the firewallERR_CONNECTION_REFUSED

“Check your Internet connectionCheck any cables and reboot any routers, modems, or other network devices you may be using.Allow Chromium to access the network in your firewall or antivirus settings.If it is already listed as a program allowed to access the network, try removing it from the list and adding it again.If you use a proxy server…Check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don’t believe you should be using a proxy server: Go to Applications > System Preferences > Network > Advanced > Proxies and deselect any proxies that have been selected.”

Thanks
hartfort


#2
  1. Check the process is running.
  2. Check Gogs log (path/to/gogs/log/gogs.log)

#3

Hello, Thanks!

The process was not running - I had to restart it, but even after starting it I don’t see gogs running when I do the TOP command in terminal. I checked the gogs.log file and discovered that the host was 0.0.0.0:3306, so I changed that to my domain name, restarted the service, it ran for a bit and then shut down as before.

Still back to my original issue. Any other advice?


#4

Hello, I have the same issue too. Gogs Version: 0.11.29 @ 2017-08-15, apache, centos 7 built in mysqlite3 Did you ever find a fix? Anyone else have this issue?
I really like gogs but this is frustrating.
Zhozo


#5

Unfortunately, no. gogs refuses to stay running. Runs for about 15 minutes or so, then it’s gone with the error above. I tried reinstalling several times on clean servers even. Very strange. You might want to try out GITEA.

hartfort