Gogs does not pusblish on feeds from control panel after migration

Hi everyone! I have migrated from Windows to CentOS succesfully but after face and resolve several issues I am not being able to visualize feeds from Control Panel corresponding to my migrated repos but I am capable of seeing feeds from repos created in this migrated server. Also I realized that theirs commits do not appear on action database table. How can I solved this?

In /admin panel, try:

I just forgot to mention I had done that and did not resolve anything. I have read also about mount point containing the repositories is not set as noexec but I must say I did not understood the stuff.

Please post commands and output you used to push a repo, including the SSH/HTTP URL (hide domain name if publicly accessible).

Hi! I have got established the origin as https://XXX:PORT/repositories/MyRepo.git and I just push doing git push origin develop or just git push with a common output like the next one:

It does not look like the way you have in the screenshot, the actual URL you push has three slashes / where you are supposed to only have two (unless you’re visiting Gogs with a subpath?).

The correct one is that of the screenshot. Both for pushing and accessing through Gogs URLs are the same: https://XXX:PORT/repositories/Organization/MyRepo.git is the URL for the repo and https://XXX:PORT/repositories is the URL for accessing Gogs.

Hi! Must I still hoping for help and a solution for this issue or must I ignore it?

I see. It could also be caused by Git hook failure. Check if there is any logs in path/to/gogs/logs/hooks right after a push?

I checked the existence of files in path/to/gogs/log/hooks and in fact there are three files there: post-receive, post-update and update but ampty.

I think… I know the problem.

Change the following config to http://XXX:PORT/repositories/ should solve the problem:

Or more generic for your case: %(PROTOCOL)s://%(HTTP_ADDR)s:%(HTTP_PORT)s/repositories/

Hi dear friend! I had make your suggestion on the file path/to/gogs/custom/conf/app.ini as you are able to see next:

Screenshot_12

I had to add the PROTOCOL, HTTP_ADDR before but that did not make a change to work :frowning: yet.

Also I reviewed the directory path/to/gogs/log/hooks and still empty files except for post-receive.log file that contains now:

Good find! The last line of log indicates the problem, it received not 2xx response code.

Could you enable trace level logging by changing your custom app.ini similar to follows:

[log]
LEVEL = Trace

This will print the actual URL it tries to send requests to, after you made another push.

Hi!

I made what you suggested but after that Gogs has not logged something in path/to/gogs/log/hooks yet.

You need to a git push of a repository with some changes to trigger the operation that produces the log, have you done that?

Yeah, I made changes on my repository and then pushed them to the remote repository and nothing happened on logs.

Hmm… I’m running out of ideas, which Gogs version are you using?

Even if there is no trace logs, you should at least have the same error message you posted earlier.

Gog’s version is 0.11.53.0603.

I have been thinking about the possibility of some DB data in some table which is out of date and that’s causing feeds not appearing on page. Is that possible? I could fix a problem related to that in the past when issues were not showing themselves on page and that was because some registers made references to directories path from old server.

OK… in that version, the bug of log level could still exist, to enable trace level log (if you’re using “file”, same for console):

[log.file]
LEVEL = Trace

The next step I can think of is to manually check the test repository on your server, then go to path_to_repo/hooks, and look at content of three scripts: pre-receive, update, and post-receive.