Fatal: repository not found after 0.10.1 update

After updating to 0.10.1.0228 I get notice from Tower when trying to push to a private repo:

fatal: repository ‘https://[email protected]/user/Repo/’ not found

From the log:

2017/03/05 11:32:32 [TRACE] Session ID: 96xxxxx
2017/03/05 11:32:32 [TRACE] CSRF Token: DDxxxxx
2017/03/05 11:32:32 [TRACE] Template: status/404

Some additional information about my setup, if necessary.

  • Using apace + proxy

Edit: Created new repository, able to push and pull as expected. Still looking into why previously created repositories are throwing errors.

Try deleting browser cookies. Also make sure the configuration remains as it should (server name, port, etc.). Post back and let us know.

Browser is not an issue, everything works via the GUI.

I’m having an issue with the stand alone Git application Tower. Repositories created prior to the update return a 404, which can be seen in Gog’s logs. I created a new repository today, cloned via Tower and everything worked as expected.

The problem would likely be resolved by removing and re-cloning these repositories, I’m just not ready to delete the local copies just yet. I could move the files, re-clone, and move back, but I’m hoping to resolve by fixing the problem instead of reverting to each local .git folder.

Edit: Only change to the app.ini in this time was to disable SSH. I’ve reverted, tested, no fix.

I use Tower too (2.6.1), using Apple’s git 2.10.1 and Kaleidoscope for diff. What do you mean return a 404? When you fetch? Could you post a screenshot?

Tower returns the “fatal:” error in a dialog box titled “Can’t Find Remote Repository”.

The 404 is recorded in Gog’s logs. I copied the lines above. In a standard install logs can be read under /gogs/log/.

fatal: repository ‘https://[email protected]/user/Repo/’ not found

That line is wrong, I think. Is this what you see under account settings (with your server/username information)?

@Fastidious thanks for the suggestions but I think this is resolved.

Adding .git to each of the previously working repositories did the trick.

How to fix 404 in Tower:

  1. Go to a repository in question
  2. Under “Remotes” click “origin”
  3. Hover over Push URL and click Set
  4. Add .git to your repository end point

All previously working private repositories are responding as they did before the 0.10.1.0228 update.

That is weird. Adding a .git simply means they were not a git repository at all (.git contains lots of other information inside). Anyway, glad you got it to work.

@Fastidious They were always repositories, as I mentioned numerous times before they were working.

I added .git to the repository end point, I did not create a hidden folder.

In your Tower app, please run through those steps I mentioned above. This may give you a better understanding of what exactly I am referring to.

Ah, yes, a reponame.git indicates a bare repository.

@Fastidious good effort debugging. Hopefully this helps someone else.

Ah, this is a fixed problem on develop branch already.

Do you expect the dev branch to make to a stable binary soon? If not I’ll build from source in the next few days.

Your lucky day, new release in next few hours!

1 Like
1 Like

Already updated. She’s working great captain!

Thanks for the quick fix and binary!

1 Like