Authentication failed with correct user/password (docker install)


#1

Hi,

I installed yesterday the last version of gogs in docker way, on debian 8.
The install and config is ok, execpt I can’t push to origin master by https from my PC. I got an error of Authentication:
fatal: Authentication failed for 'https://gogs.exemple.com/testy.git/

The user i’m using is authorize to write to this reposiroty, I tried to put him administrator, or just writer… same thing. I tried make an organisation, wtih a group, with differents users inside, all grant access in write. Nobody can access, always same error.

The strange thing is, gogs the URL is a local host: http://localhost:3000/poka/testy.git by reference of the docker system, so I changed to the correct URL of my domain, and the remote PC find it because he ask the user and password authentication.
Maybe this 2 problems are same. Any idea ?


#2

If Gogs says wrong, it is wrong. Or you didn’t connect to Gogs at all but something else?


#3

I fixed the problem of localhost, but still can’t authentificate:
fatal: Authentication failed for 'https://gogs.exemple.com/testy.git/


#4

I have the same problem.